HOME ARTICLES JOIN GALLERY STORE SPONSORS MARKETPLACE CONTACT US  
Register | FAQ | Search | Memberlist
Username:    Password:       Forgot your password?
BIKELAND > FORUMS > ZX-14.com > Thread: Mix-It Amplifier installed... NEW TOPIC NEW POLL POST REPLY
Goldwingmann


Expert Class
Posts: 336
posted March 28, 2012 09:06 AM        
Mix-It Amplifier installed...

Have installed a Mix-It amplifier (velcroed and Black Wire Tied) to front right fork, nicely concealed and out of the way and easy access. I plugged in the Zumo 550, along with the 9500i detector, so can boost volume into the stereo ear plugs and hear very well above incoming road wind above the windshield.

Have it on the C-14 and works very well...light weight fused to the battery for power, always works and a must have to hear those radar alerts a mile away.

Has anyone used one on their bikes?

  Ignore this member   
gilberjj


Needs a job
Friend of Fast
Posts: 3193
posted March 28, 2012 05:11 PM        
I have one on all of my fake bikes!
  Ignore this member   
Lucky14


Pro
Posts: 1439
posted March 28, 2012 09:30 PM        
quote:
I have one on all of my fake bikes!


Now THAT's funny!!!

What's next? Matching green handlebar tassels?


____________
You only need two tools: WD-40 and Duct Tape.
If it doesn't move and should, use the WD-40.
If it shouldn't move and does, use the duct tape.

  Ignore this member   
All times are America/Va < Previous Thread     Next Thread >
BIKELAND > FORUMS > ZX-14.com > Thread: Mix-It Amplifier installed... NEW TOPIC NEW POLL POST REPLY

FEATURED NEWS   Bikeland News RSS Feed

HEADLINES   Bikeland News RSS Feed


Copyright 2000-2015 Bikeland Media
Please refer to our terms of service for further information
0.27951908111572 seconds processing time