HOME ARTICLES JOIN GALLERY STORE SPONSORS MARKETPLACE CONTACT US  
Register | FAQ | Search | Memberlist
Username:    Password:       Forgot your password?
BIKELAND > FORUMS > DRAGBIKE ZONE.com > Thread: turbo not spooling completely NEW TOPIC NEW POLL POST REPLY
2kzx12turbo


Parking Attendant
Posts: 8
posted May 06, 2012 12:01 PM        
turbo not spooling completely

my zx12 turbo isnt spooling up completely. the turbo isnt froze up i can hear it whistle and the impeller spins freely and easily with my finger. the wastegate is recently lubed up and not stuck open. i noticed recently that my lockup clutch isnt locking up all of the time just once in while...before i had problems with the bike it ran good except for the shifting pin broke the weld inside of the clutch cover. maybe it fried some plates??? the bike sat for about a 1.5 years before i bought it. im stuck the only things i could think of are the plugs or the clutch. around the higher rpms it breaks up pretty bad and im getting horrible gas mileage..heres everyting that was done to it since ive had it.. valve cover gaskets and head gaskets..new mr turbo headers.( old ones cracked when i was riding it hard one nite and that started the digging into the bike) had a compression check and the motor is fine. the bike still runs hard and i can feel the turbo working a little bit but i dont think its working fully. took it to a dyno shop and they said the wastegate isnt opening so theres a loss of pressure somewhere.??? mallory racing fuel pump and regulator are ok..supposed to have 43 pounds of pressure per mr turbo..before the headers broke i could here the the wastegate working now i dont hear it. also my boost pressure guage isnt working and i know the guage is good.it has a good connection to the wastegate . the guage was tested..thats all i can think of..an ideas.. besides that the bike is flawless and runs excellent accept after im on it hard it backfires.. i can still get about 110 miles on a tank and ride it daily..ive also resealed the airbox and all of the hoses are tight..maybe adjust lockup??? any ideas would be appreciated!!!!!

  Ignore this member   
Paul2281


Expert Class
Posts: 147
posted May 06, 2012 01:05 PM        Edited By: Paul2281 on 6 May 2012 20:07
Check your waste gate again and check for any vac. leaks,or lines not hooked up or unpluged from a nipple....It won`t even make boost in neutral???
  Ignore this member   
2kzx12turbo


Parking Attendant
Posts: 8
posted May 06, 2012 01:25 PM        
no it wont boost in neutral. i was told from mr turbo that it will only boost in gear..ive rechecked all of the lines multiple times..im thinking it might be a fuel issue the way it breaks up in higher rpms..maybe the fpr isnt set right..im stumped..plugs?? the only shop is about 5 hours from me that is mostly a turbo bike shop..regular shops wont touch it. i have the instructions that came with it and everything seems in order so it has to be something i cant see.. maybe the power commander failed..damn wtf
  Ignore this member   
KZScott


Needs a life
high on speed
Posts: 7149
posted May 06, 2012 04:06 PM        
you NEED to know the AFR. if its boosting and not running properly, it could melt stuff.
____________
01 ZX-12R 8.84 @ 156.3 no bars, DOT rubber, Pump Gas NA..... turbo 8.47 @ 164
00 ZX-12R 8.62 @ 165.2 no bars, slicks, Pump Gas, 55 shot... turbo 8.32 @173
00 ZX-12R NA 1: 222.04 1.5: 226.39 Loring AFB
00 ZX-12R street turbo 1: 227.9 1.5: 234.1 Loring AFB

  Ignore this member   
2kzx12turbo


Parking Attendant
Posts: 8
posted May 06, 2012 05:36 PM        
ill have to recheck everything again before i take it to the shop..im getting the feeling that i might have to make that 5 hour drive...i wonder how often do powercomanders keep the map before it erases off of it.. the bike was sitting for 1.5 years..???
  Ignore this member   
almost_les


Zone Head
Posts: 590
posted May 06, 2012 06:58 PM        Edited By: almost_les on 7 May 2012 02:05
your injectors are dirty/clogged/varnished
  Ignore this member   
Oz Booster


Expert Class
Posts: 230
posted May 06, 2012 08:05 PM        
Look real hard for boost leaks, all the throttlebody rubbers , including between the tbs and head, block off plates, up pipe etc , i think whats happening is you have it tuned for boost on tps , and if there is little or no boost your running rich and breaking up
  Ignore this member   
2kzx12turbo


Parking Attendant
Posts: 8
posted May 06, 2012 08:53 PM        
tbs between the head..what is tbs..also tuned for boost on tps what is that also.. i defifnitley know i am running rich.i know of throttle positioning sensor wasnt sure if that is what youre trying to explain to me. i was thinking about the injectors but the bike runs fine until the higher rpms when the turbo should spool up then when im at about 9000 rpm and hit it then bike hesitates and bogs a lil bit but if i feather it it acts like it wants to go but doesnt..i do know everytime i let off of the gas then i hit it hard it backfires..definitely extra fuel..maybe not enough air from the leak or whatever is going on.. this is killing me..
  Ignore this member   
2kzx12turbo


Parking Attendant
Posts: 8
posted May 06, 2012 09:04 PM        
had a brain fart.. throttle bodies..lol.. ill recheck them again in the morning and just so i know ill reseal them again..im still lost on tps tho..
  Ignore this member   
2kzx12turbo


Parking Attendant
Posts: 8
posted May 06, 2012 09:28 PM        
also almost forgot. when i start the bike when its been sitting over nite when i use the choke itll work for about 2 minutes then the choke doesnt want to work . i have to manually use the thottle for the bike to warm up..if not it will stall..
  Ignore this member   
KZScott


Needs a life
high on speed
Posts: 7149
posted May 06, 2012 09:54 PM        
is it tuned with alpha n or speed density or blended?
____________
01 ZX-12R 8.84 @ 156.3 no bars, DOT rubber, Pump Gas NA..... turbo 8.47 @ 164
00 ZX-12R 8.62 @ 165.2 no bars, slicks, Pump Gas, 55 shot... turbo 8.32 @173
00 ZX-12R NA 1: 222.04 1.5: 226.39 Loring AFB
00 ZX-12R street turbo 1: 227.9 1.5: 234.1 Loring AFB

  Ignore this member   
2kzx12turbo


Parking Attendant
Posts: 8
posted May 06, 2012 10:04 PM        
i really dont know. i know its a mr turbo kit with a mallory fpr fuel pump and i bought the bike with it like that then the problems started when the headers broke..something musta got outta wack..at least i know the turbo is good..what is alpha n ..speed density...?? i know it has a custom mr turbo map..other than that i know the mechanicals..outta 12 bikes this is my first turbo
  Ignore this member   
Oz Booster


Expert Class
Posts: 230
posted May 09, 2012 01:53 PM        
Backfire is usually a sign of lean ,
I take it your usiong a Powercommander pc3 or similar for fuel mapping and relying on the fuel pressure regulator for boost referencing ?

alternative mapping is to use a boost referenced engine manager (PC hub is one example), that has a higher range map sensor to std and suppliments the tps fueling with pressure referenced fueling ,
with turbo you could have for example 0 boost or 5 psi at 50% throttle depending on load , the tps mapping can't cope with this alone

My comments above are looking for pressure leaks, between the head and airbox (frame), sometimes a backfire can pop the throttlebodies off the head , still engaged on the rubber enough to run if a little ragged , but not make power, also can loose boost pressure between the frame and throttlebodies , or up pipe connections

Maybe safer to test your system before you kill the motor
fuel flow and pressure can be tested by putting a regulated air supply set to max boost pressure to the fuel pressure regulator pressure reference line and capturing the fuel out of the tank return hose , and power the pump up , so you can measure output /min , aim for 1500-2000cc/min

and you can pressure test the air side with regulated air , cap the turbo inlet and pressureise the inlet system via the wastegate line , then check all hoses and joins , caps and blockoffs for leaks
10 psi should be enough

  Ignore this member   
All times are America/Va < Previous Thread     Next Thread >
Quick Reply:

Email Notification: Send all replies to your email address.
BIKELAND > FORUMS > DRAGBIKE ZONE.com > Thread: turbo not spooling completely NEW TOPIC NEW POLL POST REPLY

FEATURED NEWS   Bikeland News RSS Feed

HEADLINES   Bikeland News RSS Feed


Copyright 2000-2011 Bikeland Media
Please refer to our terms of service for further information
0.620443105698 seconds processing time