HOME ARTICLES JOIN GALLERY STORE SPONSORS MARKETPLACE CONTACT US  
Register | FAQ | Search | Memberlist
Username:    Password:       Forgot your password?
BIKELAND > FORUMS > ZX12R ZONE.com > Thread: ZX12R B2H 2005 Still having starting problems NEW TOPIC NEW POLL POST REPLY
Black Gold ZX12R


Parking Attendant
Posts: 15
posted April 30, 2014 01:30 AM        
ZX12R B2H 2005 Still having starting problems

Sorry to keep coming back asking for help but this starting problem just won't go away.

As you can all see from the thread (http://www.bikeland.org/board/viewthread.php?FID=1&TID=59943) it's been a nightmare A further battery was fitted may 2013 it started ridden to MOT 10 miles to work and back 40 miles. Following day ridden to work and back 40 miles and the next day turns over but doesn't fire up.

When running it is fantastic never misses a beat pulls in all the gears and revs to max no problem.

Just doesn't start, and what I mean by that it cranks over at a good speed Fi light blinks etc fuel pump can be heard priming all dash board indications light up as should but engine just doesn't fire up.

Anyone got any more ideas it's looking like a trip to the dealers who have said they will start changing sensors £100+ until they reach the ECU £1000 (plus labour) and hopefully they would find the problem!! But I could have a £1500+ bill and as the bike can run for months without problems find the fault returns and I've wasted my money. Any mechanics out there who have a step by step guide on how to tracked down this problem? your help would be much appreciated.

In Summary

Bike purchase May 2007 and had to immediate replace battery (Bike 2005 ZX12R B2H)
Run from May 2007 to January 2011 no problems trips to IOM Europe etc perfect

New battery (replaced because of age) January 2011 but bike won't start even with new battery but suddenly starts March 2011 runs until October 2011.

Stops running October 2011 starts again March 2012

Stops running September 2012 starts May 2013
New battery May 2013 runs two days not fired up again up to date April 2014

Kept in garage and on optimate trickle charger all times

So you can see in the 7 years I've owned it I have fitted three batteries and in the pass three years 25 months the bike won't fire up.

Serious Help is needed and I thank anyone who has any suggestions on how to get it running again

Here's the original thread

http://www.bikeland.org/board/viewthread.php?FID=1&TID=59943

  Ignore this member   
All times are America/Va < Previous Thread     Next Thread >
Quick Reply:

Email Notification: Send all replies to your email address.
BIKELAND > FORUMS > ZX12R ZONE.com > Thread: ZX12R B2H 2005 Still having starting problems NEW TOPIC NEW POLL POST REPLY

FEATURED NEWS   Bikeland News RSS Feed

HEADLINES   Bikeland News RSS Feed


Copyright 2000-2015 Bikeland Media
Please refer to our terms of service for further information
0.22975897789001 seconds processing time